Cisco router configuration for a Tele2 VDSL connection

I got myself a Cisco 887V-W to replace the Comtrend modem that Tele2 ships with their 50 Mbit VDSL connection, once called Fiber Speed. Thanks goes out to Glazenbakje for a basic VDSL config that I could tweak to get it to work with Tele2.

I’d advise to upgrade to IOS 15.1T as it holds a newer ADSL firmware that does a better job calculating the attainable rate. If you connect your router and execute the sh controllers vdsl 0 command you’ll see something like this that indicates you have a VDSL carrier signal:

Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.993.2 (VDSL2) Profile 17a
TC Mode: PTM
Selftest Result: 0x00
DELT configuration: disabled
DELT state: not running
Trellis: ON  ON
Line Attenuation:  0.0 dB  0.0 dB
Signal Attenuation:  0.0 dB  0.0 dB
Noise Margin:  6.2 dB  5.8 dB
Attainable Rate: 44884 kbits/s 5535 kbits/s
Actual Power: 14.2 dBm  1.4 dBm

And now for the basic config lines to get this going:

interface Ethernet0
no ip address
!
interface Ethernet0.32
encapsulation dot1Q 32
pppoe-client dial-pool-number 10
!
interface Vlan1
ip address 10.1.1.34 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!

interface Dialer 10
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
no ip virtual-reassembly in
encapsulation ppp
ip route-cache policy
dialer pool 10
dialer string 555
dialer-group 10
ppp authentication chap callin
ppp chap hostname <username>@3p.versatel.nl
ppp chap password 0 <your decoded password>
no cdp enable
!
ip nat inside source list 101 interface Dialer10 overload
ip route 0.0.0.0 0.0.0.0 Dialer10
!
access-list 101 permit ip 10.1.1.0 0.0.0.255 any
dialer-list 10 protocol ip permit

Notes of interest: The VLAN ID that Tele2 uses for their internet connection is 32. They have different ID’s for i.e. the management connection to the modem but you don’t need those. They use CHAP for their PPPoE identification and I needed to use a dialer string with a random number to trigger the dial out.

In case you have any questions feel free to leave a comment and I’ll try to answer to the best of my ability.

Advertisements

4 Responses to Cisco router configuration for a Tele2 VDSL connection

  1. Pingback: Tele2 Fiberspeed VDSL with a Cisco modem « Edge Technology

  2. Zsombaa says:

    Hi!

    I spend my half day to make it work, but it just doesn`t. I keep getting the following error message when turning on Dialer debugging – the DSL line is up, and working.

    … Di10: No free dialer – starting fast idle timer

    According to cisco it happens, when it the Dialer is not applied to a physical interface – but in this case it is to Ethernet0.32, right?

    Here`s my config, any help would be appreciated.
    Thanks:
    Zsomba

    Router#sh controllers vdsl 0
    Controller VDSL 0 is UP

    Daemon Status: Up

    XTU-R (DS) XTU-C (US)
    Chip Vendor ID: ‘BDCM’ ‘IKNS’
    Chip Vendor Specific: 0x0000 0x0001
    Chip Vendor Country: 0xB500 0xB500
    Modem Vendor ID: ‘CSCO’ ‘ ‘
    Modem Vendor Specific: 0x4602 0x0000
    Modem Vendor Country: 0xB500 0x0000
    Serial Number Near: FCZ142091PQ 887V-SEC 15.1(4)M
    Serial Number Far: ^A
    Modem Version Near: 15.1(4)M
    Modem Version Far: 0x0001

    Modem Status: TC Sync (Showtime!)
    DSL Config Mode: AUTO
    Trained Mode: G.993.2 (VDSL2) Profile 17a
    TC Mode: PTM
    Selftest Result: 0x00
    DELT configuration: disabled
    DELT state: not running
    Trellis: ON ON
    Line Attenuation: 0.0 dB 0.0 dB
    Signal Attenuation: 0.0 dB 0.0 dB
    Noise Margin: 6.2 dB 17.4 dB
    Attainable Rate: 65276 kbits/s 15800 kbits/s
    Actual Power: 13.6 dBm – 7.3 dBm
    Per Band Status: D1 D2 D3 U0 U1 U2 U3
    Line Attenuation(dB): 13.6 23.9 102.3 5.4 20.0 29.2 N/A
    Signal Attenuation(dB): 13.6 23.9 N/A 5.5 19.8 27.7 N/A
    Noise Margin(dB): 6.2 6.2 N/A 18.9 17.4 17.2 N/A
    Total FECS: 447 29
    Total ES: 0 0
    Total SES: 0 0
    Total LOSS: 0 0
    Total UAS: 0 0
    Total LPRS: 0 0
    Total LOFS: 0 0
    Total LOLS: 0 0
    Bit swap: 49 0

    Full inits: 1
    Failed full inits: 0
    Short inits: 0
    Failed short inits: 0

    Firmware Source File Name (version)
    ——– —— ——————-
    VDSL embedded VDSL_LINUX_DEV_01212008 (1)

    Modem FW Version: 110506_1916-4.02L.03.A2pv6C032b.d23i
    Modem PHY Version: A2pv6C032b.d23i

    DS Channel1 DS Channel0 US Channel1 US Channel0
    Speed (kbps): 0 59646 0 5975
    Previous Speed: 0 0 0 0
    Reed-Solomon EC: 0 447 0 29
    CRC Errors: 0 0 0 0
    Header Errors: 0 26 0 0
    Interleave (ms): 0.00 8.00 0.00 8.00
    Actual INP: 0.00 2.00 0.00 2.00

    Ethernet0 is up, line protocol is up
    Hardware is PQII_VDSL_ETHERNET, address is 68ef.bd6c.d03e (bia 68ef.bd6c.d03e)
    MTU 1500 bytes, BW 5975 Kbit/sec, DLY 1600 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
    Keepalive set (10 sec)
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:00:24, output hang never
    Last clearing of “show interface” counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts (0 IP multicasts)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input packets with dribble condition detected
    7 packets output, 420 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 unknown protocol drops
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    Router#sh int e0.32
    Ethernet0.32 is up, line protocol is up
    Hardware is PQII_VDSL_ETHERNET, address is 68ef.bd6c.d03e (bia 68ef.bd6c.d03e)
    MTU 1500 bytes, BW 5975 Kbit/sec, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation 802.1Q Virtual LAN, Vlan ID 32.
    ARP type: ARPA, ARP Timeout 04:00:00
    Keepalive set (10 sec)
    Last clearing of “show interface” counters never

    version 15.1
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    enable password c
    !
    no aaa new-model
    !
    memory-size iomem 10
    crypto pki token default removal timeout 0
    !
    !
    ip source-route
    !
    !
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    !
    multilink bundle-name authenticated
    license udi pid CISCO887V-SEC-K9 sn FCZ142091PQ
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    controller VDSL 0
    !
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    no ip address
    pppoe-client dial-pool-number 10
    !
    interface Ethernet0.32
    encapsulation dot1Q 32
    !
    interface BRI0
    no ip address
    encapsulation hdlc
    shutdown
    isdn termination multidrop
    !
    interface FastEthernet0
    no ip address
    !
    interface FastEthernet1
    no ip address
    !
    interface FastEthernet2
    no ip address
    !
    interface FastEthernet3
    no ip address
    !
    interface Vlan1
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    ip tcp adjust-mss 1452
    !
    interface Dialer0
    no ip address
    !
    interface Dialer10
    mtu 1492
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    no ip virtual-reassembly in
    encapsulation ppp
    ip route-cache policy
    dialer pool 10
    dialer string 555
    dialer-group 10
    ppp authentication chap callin
    ppp chap hostname XXXX@3p.versatel.nl
    ppp chap password 0 XXXXXXXXXXXX
    no cdp enable
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    !
    ip nat inside source list 101 interface Dialer10 overload
    ip route 0.0.0.0 0.0.0.0 Dialer10
    !
    access-list 101 permit ip 192.168.1.0 0.0.0.255 any
    dialer-list 10 protocol ip permit
    !
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    no login
    transport input all
    !
    scheduler max-task-time 5000
    end

    • Sander says:

      Hi Zsombaa, it seems you have the pppoe dialer configured under the ethernet 0 interface instead of the subinterface which is incorrect. Try setting it like this:

      interface Ethernet0
      no ip address
      !
      interface Ethernet0.32
      encapsulation dot1Q 32
      pppoe-client dial-pool-number 10

      And see if that works. Good luck!

  3. zsombaa says:

    Thank you!
    It looks like it did the trick! Although after this I had some trouble figuring out the Tele2 password, but now everything up and running. 🙂

%d bloggers like this: